LPCXpresso en Debian 64 bits

El IDE LPCXpresso para desarrollar con microcontroladores de NXP, al igual que el CodeWarrior de FreeScale utilizan librerias de 32 bits por lo cual es necesario instalar librerias para multi arch. En el archivo de download del LPCxpresso indica como instalar dichos paquetes en Ubuntu y en Fedora, pero para otras distros solo indica que se deben instalar las siguientes librerias:

libgtk2.0-0:i386 libxtst6:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386 libncurses5:i386 libudev1:i386 libusb-1.0:i386 libusb-0.1:i386 gtk2-engines-murrine:i386  libnss3:i386

Al hacerlo en Debian debi buscar en internet y encontre en las siguientes paginas como hacerlo:

Los pasos son: Paso 1) agregar la arquitectura i386

# dpkg --add-architecture i386

Paso 2) actualizar el sistema

# apt-get update

Paso 3) Instalar librerias multi arch

# aptitude install linux32 ia32-libs
# apt-get install ia32-libs-gtk

Paso 4) Instalar paquetes para desarrollo

# apt-get update && apt-get upgrade
# apt-get install build-essential

Paso 5) Instalar paquetes para desarrollo con micros ARM

# wget http://static.leaflabs.com/pub/codesourcery/gcc-arm-none-eabi-latest-linux32.tar.gz
# tar xvf gcc-arm-none-eabi-latest-linux32.tar.gz

Paso 6) agregar al archivo ~/.bashrc

export PATH=$PATH:~/LOCATION-TO-PATH/bin

Esos pasos bastaron para poder instalar las librerias multi arquitectura para ejecutar correctamente el LPCXpresso en Debian 7. Cualquier duda o consulta, comenten!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: